$re = '/<span.*?>\K(.*?)(?=<\/span>)/';
$str = '<span style="font-size:10.66px;">e</span><span style="font-size:10.66px;">nhancement·for·existing·report</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);