use strict;
my $str = 'get
{
int num;
lock (this.queueLock)
{
if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)
{
Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));
}
num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);
}
return num;
}
}';
my $regex = qr/if \(([^\$]+\$\<\>[^ ]+)[^\}]+\(null, ([^;]+)\);\s+}\s+([^;]+)\1(.*;)/p;
my $subst = '\\3\\2\\4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";