import re
regex = re.compile(r"if \(([^\$]+\$\<\>[^ ]+)[^\}]+\(null, ([^;]+)\);\s+}\s+([^;]+)\1(.*;)")
test_str = ("get\n"
"{\n"
"int num;\n"
"lock (this.queueLock)\n"
"{\n"
"if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)\n"
"{\n"
"Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));\n"
"}\n"
"num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);\n"
"}\n"
"return num;\n"
"}\n"
"}")
subst = "\\3\\2\\4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)