using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>";
string input = @"foobar ${name} barfoo ${name2} or ${ name3 } foobar {no} 50% off of $50 foobar {${name}} barfoo {${name2}} or { ${ name3 } } foobar {no} 50% off of $50
foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of ($50)
foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of $50 <element>here</element> there
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}