const regex = /\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{\\w+?\\}|%\\(\\w+?\\)s|<%=\\w+?%>', 'g')
const str = `foobar \${name} barfoo \${name2} or \${ name3 } foobar {no} 50% off of \$50 foobar {\${name}} barfoo {\${name2}} or { \${ name3 } } foobar {no} 50% off of \$50
foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of (\$50)
foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of \$50 <element>here</element> there
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}