$re = '/(?<=\()[^()]*(?=\))/i';
$str = '((1,01/31/2015)(1,Filepath)(1,name)(1,code)(1,String)(1, ))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);