re = /(?<=\()[^()]*(?=\))/i
str = '((1,01/31/2015)(1,Filepath)(1,name)(1,code)(1,String)(1, ))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end