import re
regex = re.compile(r"(?<=\()[^()]*(?=\))", flags=re.IGNORECASE)
test_str = "((1,01/31/2015)(1,Filepath)(1,name)(1,code)(1,String)(1, ))"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")