const regex = /^(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps)(?:,(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps))*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i:(?:6553[0-5]|655[0-2]\\d|65[0-4]\\d\\d|6[0-4]\\d{3}|[0-5]\\d{4}|\\d{1,4})(?:-(?:6553[0-5]|655[0-2]\\d|65[0-4]\\d\\d|6[0-4]\\d{3}|[0-5]\\d{4}|\\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps)(?:,(?i:(?:6553[0-5]|655[0-2]\\d|65[0-4]\\d\\d|6[0-4]\\d{3}|[0-5]\\d{4}|\\d{1,4})(?:-(?:6553[0-5]|655[0-2]\\d|65[0-4]\\d\\d|6[0-4]\\d{3}|[0-5]\\d{4}|\\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps))*$', '')
const str = `0-154,any`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}