// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps)(?:,(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps))*$").unwrap();
let string = "0-154,any";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}