re = /^(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps)(?:,(?i:(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4})(?:-(?:6553[0-5]|655[0-2]\d|65[0-4]\d\d|6[0-4]\d{3}|[0-5]\d{4}|\d{1,4}))?|any|rpc|rpc-epmap|teredo|iphttps))*$/
str = '0-154,any'
# Print the match result
str.match(re) do |match|
puts match.to_s
end