using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)/([^/\s]{10,})/$";
string input = @"people-news/gayd-park-privodyat-v-poryadok/
news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/
news/society/
news/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}