re = /^(.+)\/([^\/\s]{10,})\/$/m
str = 'people-news/gayd-park-privodyat-v-poryadok/
news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/
news/society/
news/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end