import re
regex = re.compile(r"^(.+)/([^/\s]{10,})/$", flags=re.MULTILINE)
test_str = ("people-news/gayd-park-privodyat-v-poryadok/\n"
"news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/\n"
"news/society/\n"
"news/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")