package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{10,})/(.+)/$`)
var str = `people-news/gayd-park-privodyat-v-poryadok/
news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/
news/society/
news/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}