$re = '~^(.{10,})/(.+)/$~m';
$str = 'people-news/gayd-park-privodyat-v-poryadok/
news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/
news/society/
news/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);