use strict;
my $str = 'people-news/gayd-park-privodyat-v-poryadok/
news/society/nedorogie-pamyatniki-na-mogilu-eto-ne-znachit-plokhoe-kachestvo/
news/society/
news/';
my $regex = qr~^(.{10,})/(.+)/$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}