#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[(test|test2)(?![\w-]).*?\](?!["])(.*?\[\/(\2)\])?)"
Local $sString = "[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]" & @CRLF & _
"[ct_col col="4"][test2 text="Test Text" email="example@gmail.com" textarea="Test Text" editor="Test Text" select="test2" radio="test2" checkbox="test2" radio_image="test2" checkbox_image="test2" radio_button="test2" checkbox_button="test1,test3" text_multi="test 1,test 2" number="50" range="50" dimension="20,px" Icon="fa fa-cogs" color="#ff00ff" rgba="rgba(25,56,58,0.65)" font_style="[object Object]" text_align="left" image="[]" font="[]"][/ct_col]" & @CRLF & _
"[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]" & @CRLF & _
"[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test][/ct_col]" & @CRLF & _
"[ct_col col="4"][test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2][/ct_col]" & @CRLF & _
"[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2] ssd[/test][/ct_col]" & @CRLF & _
"[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test] ssd[/test][/ct_col]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")