re = /(\[(test|test2)(?![\w-]).*?\](?!["])(.*?\[\/(\2)\])?)/
str = '[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]
[ct_col col="4"][test2 text="Test Text" email="example@gmail.com" textarea="Test Text" editor="Test Text" select="test2" radio="test2" checkbox="test2" radio_image="test2" checkbox_image="test2" radio_button="test2" checkbox_button="test1,test3" text_multi="test 1,test 2" number="50" range="50" dimension="20,px" Icon="fa fa-cogs" color="#ff00ff" rgba="rgba(25,56,58,0.65)" font_style="[object Object]" text_align="left" image="[]" font="[]"][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test][/ct_col]
[ct_col col="4"][test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2] ssd[/test][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test] ssd[/test][/ct_col]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end