using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>(?:[^](?!<\/p>))*<h[1-6]>";
string input = @"<p> ... <h1>
<p> ... </p><h1>
<P> Hello
<h1>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}