re = /<p>(?:[^](?!<\/p>))*<h[1-6]>/i
str = '<p> ... <h1>
<p> ... </p><h1>
<P> Hello
<h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end