const regex = /(^\+)?[^\d]+/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\+)?[^\\d]+', 'mg')
const str = `41815422`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);