using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^\)\)\)]*)\)\)\)[\s]*,?";
string input = @"((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,
((Test_1, (3.7, 88, test,, str))), (Test_2, (1.9, 33, test,, str))) ,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}