$re = '/\(([^\)\)\)]*)\)\)\)[\s]*,?/m';
$str = '((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,
((Test_1, (3.7, 88, test,, str))), (Test_2, (1.9, 33, test,, str))) ,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);