import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([^\\)\\)\\)]*)\\)\\)\\)[\\s]*,?";
final String string = "((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,\n\n"
+ "((Test_1, (3.7, 88, test,, str))), (Test_2, (1.9, 33, test,, str))) ,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}