using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^172\.18\.(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.)([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-9])$";
string substitution = @"";
string input = @"172.18.0.255
185.25.14.263
172.15.12.0
172.18.255.255
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}