import re
regex = re.compile(r"^172\.18\.(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.)([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-9])$", flags=re.MULTILINE)
test_str = ("172.18.0.255\n"
"185.25.14.263\n"
"172.15.12.0\n"
"172.18.255.255\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)