re = /^172\.18\.(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.)([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-9])$/m
str = '172.18.0.255
185.25.14.263
172.15.12.0
172.18.255.255
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result