package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`symbol.+?([A-Z]{2,5})`)
var str = ` New York Stock Exchange (NYSE) under the symbol "KDMN."`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}