re = /symbol.+?([A-Z]{2,5})/
str = ' New York Stock Exchange (NYSE) under the symbol "KDMN."'
# Print the match result
str.match(re) do |match|
puts match.to_s
end