$re = '/symbol.+?([A-Z]{2,5})/';
$str = ' New York Stock Exchange (NYSE) under the symbol "KDMN."';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);