import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+?(?<COUNTRY_CODE>\\d{1})?-?\\(?(?<AREA_CODE>\\d{3})\\)?[\\s-\\.]?)?(?<PART1>\\d{3})[\\s-\\.]?(?<PART2>\\d{4})[\\s-\\.]?";
final String string = "+1-(800)-123-4567\n"
+ "2-(800)-123-4567\n"
+ "3-800-123-4567\n"
+ "123-456-7890\n"
+ "123 456 7890\n"
+ "(123) 456 7890\n"
+ "(123)-456-7890\n"
+ "1234567890\n"
+ "123.456.7890\n"
+ "123.4567\n"
+ "123-4567\n"
+ "1234567900\n"
+ "12345678900";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}