$re = '/(?:\+?(?<COUNTRY_CODE>\d{1})?-?\(?(?<AREA_CODE>\d{3})\)?[\s-\.]?)?(?<PART1>\d{3})[\s-\.]?(?<PART2>\d{4})[\s-\.]?/m';
$str = '+1-(800)-123-4567
2-(800)-123-4567
3-800-123-4567
123-456-7890
123 456 7890
(123) 456 7890
(123)-456-7890
1234567890
123.456.7890
123.4567
123-4567
1234567900
12345678900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);