// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\+?(?<COUNTRY_CODE>\d{1})?-?\(?(?<AREA_CODE>\d{3})\)?[\s-\.]?)?(?<PART1>\d{3})[\s-\.]?(?<PART2>\d{4})[\s-\.]?").unwrap();
let string = "+1-(800)-123-4567
2-(800)-123-4567
3-800-123-4567
123-456-7890
123 456 7890
(123) 456 7890
(123)-456-7890
1234567890
123.456.7890
123.4567
123-4567
1234567900
12345678900";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}