using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\( *([A-Z]+[a-z]+)[A-za-z]*\)|\(([a-z]+[A-Z]+[A-za-z]*) *\)";
string input = @"(LOWERUPPER) (lowerupper) (LowerUpper) (upperLower) other text ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}