re = /\( *([A-Z]+[a-z]+)[A-za-z]*\)|\(([a-z]+[A-Z]+[A-za-z]*) *\)/m
str = '(LOWERUPPER) (lowerupper) (LowerUpper) (upperLower) other text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end