package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\( *([A-Z]+[a-z]+)[A-za-z]*\)|\(([a-z]+[A-Z]+[A-za-z]*) *\)`)
var str = `(LOWERUPPER) (lowerupper) (LowerUpper) (upperLower) other text `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}