# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *(<br *\\/*> *)+/ /;t' <<< "after 15 rounds. <br /> <br > <br /> <br> Burgess"