using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bYii::t\(')(?:[^'\\]|\\.)+(?=',\s*'Create'\))";
string input = @"Yii::t('\'something\'', 'Create')
Yii::t('bla bla', 'Create')
Yii::t('cmdshdfjs', 'Create')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}