$re = '/(?<=\bYii::t\(\')(?:[^\'\\\\]|\\\\.)+(?=\',\s*\'Create\'\))/';
$str = 'Yii::t(\'\\\'something\\\'\', \'Create\')
Yii::t(\'bla bla\', \'Create\')
Yii::t(\'cmdshdfjs\', \'Create\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);