re = /(?<=\bYii::t\(')(?:[^'\\]|\\.)+(?=',\s*'Create'\))/
str = 'Yii::t(\'\\\'something\\\'\', \'Create\')
Yii::t(\'bla bla\', \'Create\')
Yii::t(\'cmdshdfjs\', \'Create\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end