import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.*?\\](?:(?:,|\\s+and\\s+)\\s*\\[.*?\\](?:\\s+and\\s+\\[.*?\\])*)*";
final String string = "[Name]\n"
+ "[Name 1], [Name 2]\n"
+ "[Name 1] and [Name 2]\n"
+ "[Name 1], [Name 2] and [Name 3]\n"
+ "[Name 1], [Name 2] and [Name 3], [Role]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}