$re = '/\[.*?\](?:(?:,|\s+and\s+)\s*\[.*?\](?:\s+and\s+\[.*?\])*)*/m';
$str = '[Name]
[Name 1], [Name 2]
[Name 1] and [Name 2]
[Name 1], [Name 2] and [Name 3]
[Name 1], [Name 2] and [Name 3], [Role]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);