package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{8}_(\d+|end)$`)
var str = `20200509_1234567
20200509_end
20200509_ (invalid)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}