$re = '/^\d{8}_(\d+|end)$/m';
$str = '20200509_1234567
20200509_end
20200509_ (invalid)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);