re = /^\d{8}_(\d+|end)$/m
str = '20200509_1234567
20200509_end
20200509_ (invalid)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end