using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{5,32}$)[^\W0-9_][^\W_]*(?:_[^\W_]+)*$";
string input = @"abc_12abc
abc_12_abc
abc_12__abc
abc_12_abc_
_abc_12_abc
1abc_12_abc
_abc_12_abc
_abc_12_abc_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}