$re = '/^(?=.{5,32}$)[^\W0-9_][^\W_]*(?:_[^\W_]+)*$/m';
$str = 'abc_12abc
abc_12_abc
abc_12__abc
abc_12_abc_
_abc_12_abc
1abc_12_abc
_abc_12_abc
_abc_12_abc_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);