const regex = /^(?=.{5,32}$)[^\W0-9_][^\W_]*(?:_[^\W_]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{5,32}$)[^\\W0-9_][^\\W_]*(?:_[^\\W_]+)*$', 'gm')
const str = `abc_12abc
abc_12_abc
abc_12__abc
abc_12_abc_
_abc_12_abc
1abc_12_abc
_abc_12_abc
_abc_12_abc_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}