#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:[-x+]\h*may(?:15)?|may(?:15)?\h*[-x+])(*SKIP)(*F)|may(?:15)?"
Local $sString = "x May15 > WRONG" & @CRLF & _
"- May15 > WRONG" & @CRLF & _
"+ May15 > WRONG" & @CRLF & _
"xMay15 > WRONG" & @CRLF & _
"-May15 > WRONG" & @CRLF & _
"+May15 > WRONG" & @CRLF & _
"May15 > TRUE" & @CRLF & _
"May15, > TRUE" & @CRLF & _
"May15 + > FALSE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")